Site Announcements

Liebe Gäste des Forums, wir freuen uns, dass ihr zu uns gelangt seid.
Windev ist eine sehr umfangreiche und starke Entwicklerumgebung für Anwendungen unter Windows, Linux und Internetapplikationen inkl. Mobile.
Hier sind Antworten und Anregungen dazu zu finden!
Möchtest du aktiv mitschreiben? Dann melde dich durch Klick auf den Text "Registrieren" hier rechts oberhalb an.

Probleme mit Internal components.

Übergeordnete Themen zum gesamten Paket passend

Probleme mit Internal components.

Beitragvon satmax » 15. Januar 2017, 17:45

Ich habe ein Projekt "Repository" angelegt und darin verschiedenen internal components angelegt.

Dann habe ich ein neues Projekt geöffnet uns versucht aus meinem Repository eine Internal components hinzuzufügen. Im ersten Moment schein das auch zu klappen. Schließe ich aber das Projekt und öffne es neu sind alle hinzugefügten Internal components im Projekt explorer nicht mehr sichtbar!
satmax
Member
 
Beiträge: 159
Registriert: 24. September 2015, 10:05
Wohnort: Biberbach, Austria
Has thanked: 0 time
Have thanks: 1 time

Re: Probleme mit Internal components.

Beitragvon Herbert » 16. Januar 2017, 00:09

Code: Alles auswählen
An internal component is used to group several project elements. This grouping is used to:

    Organize a project: the internal components can be used to group the project elements by feature for example.
    Share the elements among several projects: The elements found in an internal component can be shared between several projects via the SCM. See Sharing an internal component for more details.

Aus http://doc.windev.com/en-US/?2014100&product=WD&productversion=XXA15005

Also nur, wenn du SCM einsetzt.

Sonst must du ein external component erstellen.
Herbert
Site Admin
 
Beiträge: 354
Registriert: 23. Februar 2010, 08:06
Wohnort: Langenthal, Schweiz
Has thanked: 5 times
Have thanks: 3 times

Re: Probleme mit Internal components.

Beitragvon satmax » 16. Januar 2017, 07:15

Ja, natürlich. SCM ist im Einsatz, könnte ich mir bei 2 Entwickler ohne gar nicht vorstellen. Ich habe es dann so gelöst:
Projekt neu aus SCM ausgecheckt (vorher lokal gelöscht).
alle 5 internal components hinzugefügt
ALLE Compilerfehler behoben (Syntax).
Projekt komplett neu erstellt (EXE)
Projekt via Windev gesichert.

Dann hat es funktioniert. Möglicherweise waren die Compilerfehler die Ursache.... Jetzt passt es wieder.
satmax
Member
 
Beiträge: 159
Registriert: 24. September 2015, 10:05
Wohnort: Biberbach, Austria
Has thanked: 0 time
Have thanks: 1 time


Zurück zu Allgemeines

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste

cron